Cisco Router Challenge 78

 

Outline

 

This challenge involves the configuration of BGP. The objectives of this challenge are to:

 

 

Commands

 

# config t

(config)# hostname leeds

leeds (config)# router bgp 172

leeds (config-router)# network 205.8.87.0

leeds (config-router)# neighbor 192.168.1.0 remote-as 100

leeds (config-router)# neighbor 192.168.1.0 update-source loopback0

 

Example

 

# config t

(config)# hostname leeds

(config)# router bgp 172

(config-router)# network 205.8.87.0

(config-router)# neighbor ?

  A.B.C.D  Neighbor address

  WORD     Neighbor tag

 

Router(config-router)# neighbor 192.168.1.0 ?

  activate                Enable the Address Family for this Neighbor

  advertise-map           specify route-map for conditional advertisement

  advertisement-interval  Minimum interval between sending BGP routing updates

  allowas-in              Accept as-path with my AS present in it

  default-originate       Originate default route to this neighbor

  description             Neighbor specific description

  distribute-list         Filter updates to/from this neighbor

  ebgp-multihop           Allow EBGP neighbors not on directly connected

                          networks

  filter-list             Establish BGP filters

  local-as                Specify a local-as number

  maximum-prefix          Maximum number of prefix accept from this peer

  next-hop-self           Disable the next hop calculation for this neighbor

  next-hop-unchanged      Propagate the iBGP paths's next hop unchanged for

                          this neighbor

  password                Set a password

  peer-group              Member of the peer-group

  prefix-list             Filter updates to/from this neighbor

  remote-as               Specify a BGP neighbor

  remove-private-AS       Remove private AS number from outbound updates

  route-map               Apply route map to neighbor

  route-reflector-client  Configure a neighbor as Route Reflector client

  send-community          Send Community attribute to this neighbor

  shutdown                Administratively shut down this neighbor

  soft-reconfiguration    Per neighbor soft reconfiguration

  timers                  BGP per neighbor timers

  translate-update        Translate Update to MBGP format

  unsuppress-map          Route-map to selectively unsuppress suppressed routes

  update-source           Source of routing updates

  version                 Set the BGP version to match a neighbor

  weight                  Set default weight for routes from this neighbor

 

(config-router)# neighbor 1.2.3.4 remote- ?

  <1-65535>  AS of remote neighbor

 

(config-router)# neighbor 1.2.3.4 remote- 1 ?

  <cr>

 

(config-router)# neighbor 192.168.1.0 remote-as 100

(config-router)# neighbor 192.168.1.0 up ?

  BRI           ISDN Basic Rate Interface

  FastEthernet  FastEthernet IEEE 802.3

  Loopback      Loopback interface

  Null          Null interface

  Serial        Serial

(config-router)# neighbor 192.168.1.0 update-source loopback0

 

Topology

 

The basic topology is defined below, where AS1 is connected to E0, AS2 to S0, and AS3 to S1.