Cisco Router Challenge 84

 

Outline

 

This challenge involves the configuration of BGP for a default local-preference using a route-map.The objectives of this challenge are to:

 

 

Commands

 

# config t

(config)# access-list 1 permit 1 10.0.0.0 0.0.0.255

(config)# route-map test

(config-route-map)# match ip address 1

(config-route-map)# set local-preference 14

(config-route-map)# exit

(config)# router bgp 172

(config-router)# neighbor 11.11.11.11 remote-as 300

(config-router)# neighbor 11.11.11.11 route-map test out

(config-router)# network 160.0.0.0

 

Example

 

# config t

(config)# access-list 1 permit 1 10.0.0.0 0.0.0.255

(config)# route-map test

Router(config-route-map)# ?

Route Map configuration commands:

  default      Set a command to its defaults

  description  Route-map comment

  exit         Exit from route-map configuration mode

  help         Description of the interactive help system

  match        Match values from routing table

  no           Negate a command or set its defaults

  set          Set values in destination routing protocol

(config-route-map)# match ?

  as-path       Match BGP AS path list

  community     Match BGP community list

  extcommunity  Match BGP/VPN extended community list

  interface     Match first hop interface of route

  ip            IP specific information

  length        Packet length

  metric        Match metric of route

  route-type    Match route-type of route

  tag           Match tag of route

(config-route-map)# m ip ?

  address       Match address of route or match packet

  next-hop      Match next-hop address of route

  route-source  Match advertising source address of route

(config-route-map)# match ip address ?

  <1-199>      IP access-list number

  <1300-2699>  IP access-list number (expanded range)

  WORD         IP access-list name

  prefix-list  Match entries of prefix-lists

  <cr>

(config-route-map)# match ip address 1

(config-route-map)# set ?

  as-path           Prepend string for a BGP AS-path attribute

  automatic-tag     Automatically compute TAG value

  comm-list         set BGP community list (for deletion)

  community         BGP community attribute

  dampening         Set BGP route flap dampening parameters

  default           Set default information

  extcommunity      BGP extended community attribute

  interface         Output interface

  ip                IP specific information

  level             Where to import route

  local-preference  BGP local preference path attribute

  metric            Metric value for destination routing protocol

  metric-type       Type of metric for destination routing protocol

  origin            BGP origin code

  tag               Tag value for destination routing protocol

  traffic-index     BGP traffic classification number for accounting

  weight            BGP weight for routing table

(config-route-map)# set local-preference?

  <0-4294967295>  Preference value

  <cr>

(config-route-map)# set local-preference 14

(config-route-map)# exit

(config)# router bgp 172

(config-router)# nei 1.2.3.4 remote-as ?

  <1-65535>  AS of remote neighbor

 

(config-router)# nei 1.2.3.4 remote-as 300 ?

  <cr>

(config-router)# neighbor 11.11.11.11 remote-as 300

(config-router)# neighbor 11.11.11.11 route-map test ?

  in   Apply map to incoming routes

  out  Apply map to outbound routes

 

(config-router)# neighbor 11.11.11.11 route-m test in ?

  <cr>

(config-router)# neighbor 11.11.11.11 route-map test out

(config-router)# network 160.0.0.0

 

Topology

 

The basic topology is defined below, where AS1 is connected to E0, AS2 to S0, and AS3 to S1.