Objectives

This challenge involves the configuration of a passive interface with EIGRP using a distribute-list.The objectives of this challenge are to:

Commands

# config t
(config)# router eigrp 128
(config-router)# network 192.168.0.0
(config-router)# distribute-list 10 out s0
(config-router)# exit
(config)# access-list 10 deny any

Example

# config t
(config)# router eigrp 128
(config-router)#?
Router configuration commands:
  address-family       Enter Address Family command mode
  auto-summary         Enable automatic network number summarization
  default              Set a command to its defaults
  default-information  Control distribution of default information
  default-metric       Set metric of redistributed routes
  distance             Define an administrative distance
  distribute-list      Filter networks in routing updates
  eigrp                EIGRP specific commands
  exit                 Exit from routing protocol configuration mode
  help                 Description of the interactive help system
  maximum-paths        Forward packets over multiple paths
  metric               Modify EIGRP routing metrics and parameters
  neighbor             Specify a neighbor router
  network              Enable routing on an IP network
  no                   Negate a command or set its defaults
  offset-list          Add or subtract offset from RIP metrics
  passive-interface    Suppress routing updates on an interface
  redistribute         Redistribute information from another routing protocol
  timers               Adjust routing timers
  traffic-share        How to compute traffic share over alternate paths
  variance             Control load balancing variance
(config-router)# network 192.168.0.0
(config-router)# distribute-list 10 out s0
(config-router)# exit
(config)# access-list 10 deny any

Explanation

The distribute-list is used to define the routing information that a device sends or receives. For example:

(config-router)# distribute-list 10 out s0
(config-router)# exit
(config)# access-list 10 deny any

defines that all the routes for S0 will be denied for outgoing updates, thus S0 is a passive interface.