Cisco Router Challenge 35

 

Outline

 

This challenge involves the configuration of OSPF. The objectives of this challenge are to:

 

 

Commands

 

> en

# config t

(config)# router ospf 146

(config-router)# network 211.79.208.0 0.0.0.255 area 0

(config-router)# network 130.184.0.0 0.0.0.255 area 0

(config-router)# network 206.198.48.0 0.0.0.255 area 0

(config-router)# area 0 range 192.168.64.0 255.255.255.0

(config-router)# exit

(config)# int e0

(config-if)# ip address 211.79.215.7 255.255.255.0

(config-if)# ip ospf hello-interval 26

(config-if)# ip ospf dead-interval 9

 

Example

 

> en

# config t

(config)# router ospf ?

 <1-65535>  Process ID

(config)# router ospf 146

(config-router)# ?

Router configuration commands:

  area                   OSPF area parameters

  auto-cost              Calculate OSPF interface cost according to bandwidth

  capability             Enable specific OSPF feature

  compatible             OSPF compatibility list

  default                Set a command to its defaults

  default-information    Control distribution of default information

  default-metric         Set metric of redistributed routes

  discard-route          Enable or disable discard-route installation

  distance               Define an administrative distance

  distribute-list        Filter networks in routing updates

  domain-id              OSPF domain-id

  domain-tag             OSPF domain-tag

  exit                   Exit from routing protocol configuration mode

  help                   Description of the interactive help system

  ignore                 Do not complain about specific event

  log-adjacency-changes  Log changes in adjacency state

  maximum-paths          Forward packets over multiple paths

  neighbor               Specify a neighbor router

  network                Enable routing on an IP network

  no                     Negate a command or set its defaults

  passive-interface      Suppress routing updates on an interface

  redistribute           Redistribute information from another routing protocol

  router-id              router-id for this OSPF process

  summary-address        Configure IP address summaries

  timers                 Adjust routing timers

  traffic-share          How to compute traffic share over alternate paths

(config-router)# network 211.79.208.0 0.0.0.255 area 0

(config-router)# network 130.184.0.0 0.0.0.255 area 0

(config-router)# network 206.198.48.0 0.0.0.255 area 0

(config-router)# area ?

  <0-4294967295>  OSPF area ID as a decimal value

  A.B.C.D         OSPF area ID in IP address format

(config-router)# area 0 ?

  authentication  Enable authentication

  default-cost    Set the summary default-cost of a NSSA/stub area

  nssa            Specify a NSSA area

  range           Summarize routes matching address/mask (border routers only

  stub            Specify a stub area

  virtual-link    Define a virtual link and its parameters

(config-router)# area 0 range ?

  A.B.C.D  IP address to match

(config-router)# area 0 range 192.168.64.0 ?

  A.B.C.D  IP mask for address

(config-router)# area 0 range 192.168.64.0 255.255.255.0

(config-router)# exit

(config)# int e0

(config-if)# ip address 211.79.215.7 255.255.255.0

(config-if)# ip ospf ?

  authentication       Enable authentication

  authentication-key   Authentication password (key)

  cost                 Interface cost

  database-filter      Filter OSPF LSA during synchronization and flooding

  dead-interval        Interval after which a neighbor is declared dead

  demand-circuit       OSPF demand circuit

  hello-interval       Time between HELLO packets

  message-digest-key   Message digest authentication password (key)

  mtu-ignore           Ignores the MTU in DBD packets

  network              Network type

  priority             Router priority

  retransmit-interval  Time between retransmitting lost link state

                       advertisements

  transmit-delay       Link state transmit delay

(config-if)# ip ospf hello-interval ?

  <1-65535>  Seconds   

(config-if)# ip ospf hello-interval 26

(config-if)# ip ospf dead-interval 9