Cisco Router Challenge 100

 

Outline

 

This challenge involves the configuration of the redistribution of routes. The objectives of this challenge are to:

 

 

Commands

 

# config t

(config)# router rip

(config-router)# passive-interface s0

(config-router)# passive-interface s1

 (config-router)# exit

(config)# router ospf 33

(config-router)# network 20.0.0.0 area 0

(config-router)# network 30.0.0.0 area 0

(config-router)# redistribute rip subnets

 

Example

 

# config t

(config)# router rip

(config-router)# passive-interface s0

(config-router)# passive-interface s1

(config-router)# exit

(config)# router ospf 33

Router(config-router)# ?

Router configuration commands:

  area                   OSPF area parameters

  auto-cost              Calculate OSPF interface cost according to bandwidth

  capability             Enable specific OSPF feature

  compatible             OSPF compatibility list

  default                Set a command to its defaults

  default-information    Control distribution of default information

  default-metric         Set metric of redistributed routes

  discard-route          Enable or disable discard-route installation

  distance               Define an administrative distance

  distribute-list        Filter networks in routing updates

  domain-id              OSPF domain-id

  domain-tag             OSPF domain-tag

  exit                   Exit from routing protocol configuration mode

  help                   Description of the interactive help system

  ignore                 Do not complain about specific event

  limit                  Limit a specific OSPF feature

  log-adjacency-changes  Log changes in adjacency state

  max-metric             Set maximum metric

  maximum-paths          Forward packets over multiple paths

  neighbor               Specify a neighbor router

  network                Enable routing on an IP network

  no                     Negate a command or set its defaults

  passive-interface      Suppress routing updates on an interface

  redistribute           Redistribute information from another routing protocol

  router-id              router-id for this OSPF process

  summary-address        Configure IP address summaries

  timers                 Adjust routing timers

  traffic-share          How to compute traffic share over alternate paths

(config-router)# network 20.0.0.0 area 0

(config-router)# network 30.0.0.0 area 0

(config-router)# redist ?

  bgp          Border Gateway Protocol (BGP)

  connected    Connected

  eigrp        Enhanced Interior Gateway Routing Protocol (EIGRP)

  isis         ISO IS-IS

  iso-igrp     IGRP for OSI networks

  metric       Metric for redistributed routes

  metric-type  OSPF/IS-IS exterior metric type for redistributed routes

  mobile       Mobile routes

  odr          On Demand stub Routes

  ospf         Open Shortest Path First (OSPF)

  rip          Routing Information Protocol (RIP)

  route-map    Route map reference

  static       Static routes

  subnets      Consider subnets for redistribution into OSPF

  tag          Set tag for routes redistributed into OSPF

  <cr>

 

(config-router)#redist rip ?

  metric       Metric for redistributed routes

  metric-type  OSPF/IS-IS exterior metric type for redistributed routes

  route-map    Route map reference

  subnets      Consider subnets for redistribution into OSPF

  tag          Set tag for routes redistributed into OSPF

  <cr>

(config-router)# redistribute rip subnets

 

Explanation

 

The following stops RIP updates into the OSPF connections:

 

(config)# router rip

(config-router)# passive-interface s0

(config-router)# passive-interface s1

 

and the following redistributes the all subnet routes:

 

(config)# router ospf 33

(config-router)# network 20.0.0.0 area 0

(config-router)# network 30.0.0.0 area 0

(config-router)# redistribute rip subnets

 

Without the redistribute rip subnet, would cause OSPF to only redistribute routes that are not subnetted (which is the default).